Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mozilla reaffirms that Firefox will continue to support current content blockers
#1
Information 
Quote:From next year onward, extensions for Google Chrome and most other Chromium-based browsers, will have to rely on a new extension manifest. Manifest V3 defines the boundaries in which extensions may operate.

[Image: firefox-105.0.1-browser.png]

Current Chromium extensions use Manifest V2 for the most part, even though the January 2023 deadline is looming over the heads of every extension developer.

Google is using its might to push Manifest v3, and most Chromium-based browsers, including Microsoft Edge, will follow. From January 2023 on, extensions need to support Manifest v3 exclusively to be listed in the Chrome Web Store. There is an Enterprise policy to extend the blocking of Manifest v2 support in Chrome by six months, but Google announced already that it won't extend that, despite delays in getting all APIs out in the open for developers.

By June 2022, Chrome and most Chromium-based browsers won't support Manifest v2 extensions anymore. Those installed will be disabled automatically, because they are no longer compatible. Those offered on the Chrome Web Store will vanish, unless their developers published an update to make them compatible with the new Manifest v3.

Mozilla announced early on that it will support Manifest v3 as well, but that it would continue to support important APIs that Google limited in Manifest v3. Probably the most important of them all is the WebRequest API. Used by content blockers extensively to filter certain items, it has been replaced by a less powerful option in Manifest v3.

While Manifest v3 does not mean the end for content blocking on Chrome, Edge and other Chromium-based browsers, it may limit abilities under certain circumstances. Users who install a single content blocker and no other extension that relies on the same relevant API may not notice much of a change, but those who like to add custom filter lists or use multiple extensions that rely on the API, may run into artificial limits set by Google.

AdGuard launched a Manifest v3 compatible ad-blocker recently, and it will display warning prompts if its operation is limited in the browser.

Mozilla reaffirmed this week that its plan has not changed. In "These weeks in Firefox: issue 124", the organization confirms that it will support the WebRequst API of Manifest v2 alongside Manifest v3.
 
Quote:Again, a reminder that Mozilla plans to continue support for the Manifest v2 blocking WebRequest API (this API powers, for example, uBlock Origin) while simultaneously supporting Manifest v3.

That is good news for users of the web browser who use content blockers such as uBlock Origin. The extension, which its developer claims operates best under Firefox, is the most popular extension for Firefox based on the number of installations and ratings.
...
Continue Reading
[-] The following 1 user says Thank You to harlan4096 for this post:
  • ismail
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username/Email:


Password:





[-]
Recent Posts
Avast Antivirus 23.1.7883
Avast Antivirus 23...harlan4096 — 09:44
AVG Anti-Virus / Internet Security 23.1....
AVG Anti-Virus / I...harlan4096 — 09:43
Macrium Reflect 8.1.7367
Macrium Reflect 8....harlan4096 — 09:39
K-Lite Codec Pack 17.4.1 / 17.4.3 Update
Changes in 17.4.3 ...harlan4096 — 09:37
Google Chrome 110.0.5481.78
Google Chrome 110....harlan4096 — 09:33

[-]
Birthdays
Today's Birthdays
avatar (46)tsorenHievy
Upcoming Birthdays
avatar (44)hapedDow
avatar (43)komriwat
avatar (35)showercurtains
avatar (46)PeterWhink
avatar (47)neuthrusBub
avatar (43)myhotseeve
avatar (43)Edwinmub
avatar (43)dimaWeami
avatar (38)svoyaEnuct
avatar (36)TranoTymn
avatar (36)MezirLal
avatar (47)listfquoto
avatar (43)dima6sarPrave
avatar (35)Michaelaburi
avatar (43)dpascoal
avatar (48)Ronaldduh
avatar (36)legalgauch
avatar (41)Baihu

[-]
Online Staff
harlan4096's profile harlan4096
Administrator

>