Dismiss this notice
Avast Premier Photo Caption - [Only registered and activated users can see links Click here to register]

Dismiss this notice
FastestVPN Accounts Giveaway - [Only registered and activated users can see links Click here to register]


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mozilla will fix add-on signing issue for older Firefox versions
#1
Information 
Quote:
[Image: firefox-add-ons-disabled.png]

Good news for Firefox users who run older versions of the web browser that are not supported anymore officially by Mozilla. Mozilla plans to release updates for these web browsers and also a standalone extension to address the add-on signing issue that caused browser add-ons to fail in all versions of the web browser.

Mozilla will release an automatic update that fixes the issue for the Firefox versions 52 through 60. Firefox users who run version 61 to 65 may install a browser extension instead to resolve the issue on their end.

Last Friday, Firefox users from around the world noticed that the Firefox browser would deactivate all installed browser add-ons. Firefox would display the notification "One or more installed add-ons cannot be verified and have been disabled" to users of the browser. All browser extensions were deactivated in the browser, and it was impossible to enable them again or download extensions from the Mozilla Add-ons website.

Mozilla has yet to publish details on how something like this could happened; from what we know, it was a certificate that expired. Since it expired, it could not be used anymore to verify add-on signatures.

Mozilla reacted and released a fix through the Firefox browser's Shield studies system at first. The organization pushed out Firefox 66.0.4 and 66.0.5 to the Stable channel, and updates for other Firefox channels as well to resolve the issue.

While that took care of supported Firefox installations, it ignored Firefox installations that were not on the most recent version of the browser.

Mozilla updated the blog post that it released on May 4, 2019 several times. Yesterday's update highlights that a fix will be released for older versions of the Firefox web browser that are not supported officially anymore.

Quote:For users who cannot update to the latest version of Firefox or Firefox ESR, we plan to distribute an update that automatically applies the fix to versions 52 through 60. This fix will also be available as a user-installable extension. For anyone still experiencing issues in versions 61 through 65, we plan to distribute a fix through a user-installable extension. These extensions will not require users to enable Studies, and we’ll provide an update when they are available. (May 8. 19:28 EDT)
[Only registered and activated users can see links Click here to register]
[-] The following 2 users Like harlan4096's post:
  • ismail, silversurfer
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Recent Posts
GFYI [Official] FastestVPN Accounts Giv...
"WHY do you wan...sgx — 04:35
GFYI [Official] FastestVPN Accounts Giv...
Thanks jason for thi...ismail — 20:07
GFYI [Official] FastestVPN Accounts Giv...
Thank you for the op...Raur — 19:01
Macrorit Disk Scanner Pro Plus Edition [...
A program to chec...ismail — 16:31
FastMove v 1.2019.807 [for PC]
Move your files...ismail — 16:21

[-]
Birthdays
Today's Birthdays
avatar (35)Isabelle88Nes
avatar (35)ferpuMip
avatar (32)kinotExaro
avatar (44)HerbertPab
Upcoming Birthdays
avatar (33)emogig
avatar (33)JasonSoult

[-]
Online Staff
There are no staff members currently online.

>